WebAutomation.LaunchInternetExplorer won't navigate to pageailable

Admin Note
-Screenshot removed-
Reason: Sensitive comment

Hi, @Roboin_Fly,

I just ran this snippet, and it opens fine.

Screenshot:

snippet

Code:

set website to 'https://nmmedicaid.portal.conduent.com/static/index.htm'

WebAutomation.LaunchInternetExplorer \
    Url:  website \
    WindowState:WebAutomation.BrowserWindowState.Normal \
    ClearCache:False \
    ClearCookies:False \
    CustomUserAgentString:'' \
    BrowserInstance=> Browser

If you can’t get this far, please post. You may have to set your IE permissions to run as administrator, or maybe run Robin.Editor.exe and possibly Robin.exe as administrator.

Also, can you please try to reach the website with Chrome and Firefox? That would narrow down the possibilities.

Best regards,
burque505

Here’s a working script (my appmask is different).

Appmask:

Code:

That’s really small, so here’s the code:

import "C:\Users\burque505\Documents\Robin\9.2\Nandini\nandini.appmask"

set website to 'https://nmmedicaid.portal.conduent.com/static/index.htm'

WebAutomation.LaunchInternetExplorer \
    Url:  website \
    WindowState:WebAutomation.BrowserWindowState.Normal \
    ClearCache:False \
    ClearCookies:False \
    CustomUserAgentString:'' \
    BrowserInstance=> Browser

set Providers to nandini.nandini.NM_MedicaidPage.ClientMenu
Set ProviderLogin to nandini.nandini.NM_MedicaidPage.ProviderLogin
set UserID to nandini.nandini.ProviderLoginPage.UserId
set Password to nandini.nandini.ProviderLoginPage.Password
set ProviderId to nandini.nandini.ProviderLoginPage.ProviderId
set LoginButton to nandini.nandini.ProviderLoginPage.LoginButton

# So far, so good.

WebAutomation.HoverOverElement \
    BrowserInstance: Browser\
    Control: ProviderLogin

wait 1

WebAutomation.Click \
    BrowserInstance: Browser\
    Control: ProviderLogin

wait 2

WebAutomation.FormFilling.PopulateTextField \
    BrowserInstance:  Browser\
    Control:  UserId \
    Text:  'gvenka19' \
    EmulateTyping:True \
    UnfocusAfterPopulate:False

wait 1

WebAutomation.FormFilling.PopulateTextField \
    BrowserInstance:  Browser\
    Control:  Password \
    Text:  'Nunny@0204' \
    EmulateTyping:True \
    UnfocusAfterPopulate:False

wait 1

WebAutomation.FormFilling.PopulateTextField \
    BrowserInstance:  Browser\
    Control:  ProviderId \
    Text:  '35138254' \
    EmulateTyping:True \
    UnfocusAfterPopulate:False

wait 1

WebAutomation.Click \
    BrowserInstance:  Browser\
    Control: LoginButton

And an animated GIF:

Hope this helps! If it doesn’t work, then I’ll bet permissions are responsible for the trouble you’re having.

Regards,
burque505

Thank you so much @burque505

But still i am facing the same issue. I think we need to change IE settings.

How can i change IE settings . Bcz in my system i am unable to use chrome and Firefox i need to work on this application in IE only.

Regards,

Hi @burque505

Insted of IE browser i have used WebAutomation.LaunchAutomationBrowser then it’s working fine.
Regards,
Robin_Fly

1 Like

Hi Team,

I want to know is this possible to comment multiple line at a time?

Regards,
Robin_Fly