AppMask Control Not Working

Hi James,
As per our discussion for the issue 4 mentioned in below link -

With Desktop Automation i mean the Automating Windows Application installed over the Machine Just Like Calculator , IBM Lotus Notes, in which if we try to interact through Elements Captured through Ui Spy, will give same kind of error or the issue is with Calculator only?

Thanks,
Pravesh

Hi Pravesh from here as well.

As I have explained during a previous question, .GetWindow action is currently under development/fixing.
You are able to extract most, if not all items from an application using UISpy.
So you could directly refer to a control instead of a window as workaround for the time being.
The application is irrelevant.
I have run an action that clicks a button in VS for example.

Best regards,
James

PS.: Since you mentioned you are currently working on a POC, feel free to upload your final project or a complete guide of the steps and the scenario you followed with the community in the “Community Projects” category. :slight_smile:


James Papadimitriou
Robin Tech Evangelist

Hi James,
U Were Right, i removed Application as well as Window Name from the Element and it started working.
Also it worked if the Calculator is already Opened, which signifies that Windows 10 Calculator Automation is Irrelevant as of now.

Also i tried Launching, Clicking and Get Element Details Actions through Winrar Application and for this application, it worked fine.

Thanks,
Pravesh

1 Like